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Lecture (1)
An Introduction to MS Excel
MS Excel is a commonly used Microsoft Office application. It is a spreadsheet program which is used to save and analyze numerical data.
In this lecture, we bring to you the important features of MS Excel, along with an overview of how to use the program, its benefits and other important elements.
1- Basics of MS Excel
Microsoft Excel is spreadsheet software that provides an interface for storing, organizing, analyzing and working with any type of information like text, numbers, and date. It can be used in business to deal with expenses, revenues, budgets, and charts. The Excel file is often referred to as a workbook and each page in the workbook is a worksheet. Worksheet is a table which is a collection of cells organized into rows and columns. Cells are really where you enter any information; you can enter text, a date, number, or formula.
Excel is a useful tool for business, scientific and statistical analysis. It can be used to:
· Manage and organize data.
· Analyze data.
· Sort Data.
· Apply Filters to data.
· Create visual representation of data using Charts.
2- Starting Microsoft Excel 
By default, a new workbook has the name Book1 with one worksheet named
Sheet1. In Sheet1 the active cell is A1.Excel file Extension is .xlsx

3- Excel interface
When you open Excel 2016 the window below will appear.
[image: ]

Select Blank workbook to create a new workbook

42

Title Bar: Title bar shows the workbook name which is by default Book1 before saving.
[image: ]

Quick Access Toolbar: It is part of Title bar it provides the most frequently used commands. You can customize the Quick Access Toolbar using drop- down arrow to the right.
[image: ]
Tabs: They appear across the top of the Ribbon and contain groups of related commands. Home, Insert, Page Layout are example of ribbon tabs.
[image: ]
[image: ]•The File tab used to do file-related operations, like open, save, create new workbook, or close.
Ribbons: contains commands organized in Groups for each tab
Name Box: contains the address of the active cell or the name of range.


Formula Bar: contains the content of the active cell.
Active Cell: The cell where you enter any information surrounded by a rectangular box.
[image: ]
Column bar: Columns are numbered as A, B, C etc. After Z, it will start series of AA, AB and so on.
Row Bar: Rows are numbered as 1, 2, 3 etc.
Worksheets: Table which is a collection of cells organized into rows and columns.   The active worksheet is bolded
[image: ]







Zoom Controls: You can slide left or right to zoom in or out.

[image: ]


Backstage view will appear when you click on the File tab on the Ribbon.
[image: ]
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[image: ]
The numbers in the screenshot
1- Click on the arrow to close Backstage view and return to Excel.
2- Info: contains information about the current workbook.
3- New: creates a new blank workbook.
4- Open: opens recent workbooks, as well as workbooks saved to your OneDrive or on your computer.
5- Save: saves the changes on the file that has already been saved.
6- Save As: Select the location, enter a file name for the workbook, and click Save. Use Save As to create a copy from original workbook using another name, different file type, and different location.
7- Close: close the current workbook.
Note that if you try to close a workbook and you haven’t saved your latest changes, Excel displays an alert message.

· Click	on	Save	to	save	your changes before closing.
· [image: ]Click on Don’t Save to close the workbook and discard these changes



Using Undo & Redo command
[image: Undo icon]To reverse the last changes, you make in a worksheet:
1. Click the Undo icon	on the Quick Access toolbar or press Ctrl+Z
from keyboard.
2. To undo more than one action, click on the arrow next to undo icon to select the actions that you want to undo.
Note:

[image: ]You can use Undo [image: Undo icon] and Redo [image: Undo icon]  (or Ctrl+Y) to switch back and forth between the actions in the worksheet.








[bookmark: _Hlk177832792][bookmark: _Hlk177983692]  Experiment (1) An Introduction to MS Excel
Create Worksheets and Workbooks:
In Excel   data is added to Worksheets, which in turn live inside Workbooks. Workbooks can be made up of just one single worksheet or of many. You can add and delete worksheets from a workbook quite easily.
To create a new blank workbook from the Start screen:
[image: ]

Create a New workbook from the Quick Access Toolbar:
Changing worksheet order:
If the worksheets in your workbook are not in the right order, you can drag and drop them into the order you need.
[image: ]

I would like to place the Coffee Sales worksheet at the front of the tabs:
1. Click and drag – you will see a little arrow and a picture of a page.
1. Drop the worksheet in the location you require.
[image: ]


[image: ]
Move or copy to a different workbook:
1. Follow the same process as before.
1. Right click on the sheet tab you wish to move or copy.
1. Click on Move or Copy.
1. In the dialog box that pops up select where you want to move the worksheet to (1).
1. Select where you want the worksheet within the workbook (2).
1. If you want a copy, tick the Create a copy box (3).
1. Click OK.
[image: ]

1.	Select where you want the copy to be placed.
2.	Click Create a copy – it should have a tick (otherwise it will move!).
[image: ]3.	Click OK.

[bookmark: _Hlk178013979][bookmark: _Hlk178014633] Answer this Questions:
· Explain MS Excel in brief
· What Are Ribbons in Excel 2019?
· How To Open the Excel 2019 Software?
· How To Open a Blank Workbook in Excel 2019?

Lecture (2)
 Entering Text and in worksheet cells
1- The Microsoft Excel Window
This Section will introduce you to the Excel window. To begin this Section, start Microsoft Excel 2007 as follows:
1. Click on Microsoft Start Button [image: ]
2. Point the mouse on All Programs
3. Click on Microsoft Office
4. Click on Microsoft Excel 2007
The Microsoft Excel window appears and your screen looks similar to the one shown here.
[image: ]
2- Cell references (addresses)
[image: ]Each cell has a cell address or reference, based on the column and row where it is located, for example cell b2 located in the column b and row 2.

Examples:
o A123, S10, AB1, AA100, BC78
Remember: Active cell	reference appears in the Name Box
Cell range is a group of selected cells. Referring to a cell range, use the reference of the first and the last cells in the range, separated by a colon (:).
Example 1:
Cell range A1:A5 include the cells A1, A2, A3, A4, and A5.
Cell range A1:C3 include the cells A1, B1, C1, A2, B2, C2, A3, B3, and C3. Cell range B1:F1 include the cells B1, C1, D1, E1, and F1.
Example 2:
How many cells in the range B1:F1?
Answer: 5 cells.
How many cells in the range A1:C3?
Answer: 9 cells.
3- Cell range is a group of selected cells. Referring to a cell range, use the reference of the first and the last cells in the range, separated by a colon (:).
4- Cut & Paste cell content: moving cell content
1. [image: ]Select the cell(s) you want to cut.
2. On the Home tab, click the Cut command on the Clipboard group, or press Ctrl+X from keyboard. The cut cells will have a dashed box.
3. Select the cells where you want to paste the content.
4. Click the Paste command on the home tab, or press Ctrl+V on your keyboard.
The cut content will be moved from the original cells and pasted into the selected cells













Experiment (2) Typing Text or Numbers into A Worksheet
	Try This Yourself:

	
	Before you begin ensure that there is a blank workbook on the screen…

	1
	Click in cell A3 to make this the active cell, type Garden Settings and press [image: ]
When you press [image: ] the next cell down automatically becomes the active cell. By the way, even though the text looks like it is in cells A3 and B3 it really only is in cell A3 – since there is nothing in B3, Excel allows the spill over to be displayed giving the illusion it is in 2 cells…

	2
	Type Pool Covers and press [image: ]

	3
	Repeat the above steps and enter the remaining text in column A as shown

	4
	Click in cell B2 to make this the active cell, type UK and press [image: ]
When you press [image: ] the cell to the right becomes the active cell…

	5
	Enter the remaining text in row 2 as shown


[image: ]Generally, when you start a new spreadsheet project, the first task is to enter some headings into rows and columns. To type anything into a worksheet you need to make the cell into which you wish to enter the data active. This can be done in a number of ways but the most common is to click in its first before typing.
[image: ]Handy to Know…
· In the exercise above we have named the workbook Garden Department Sales and filed it in C:\Course Files for Excel. Each time you start Excel it will most likely assume you want to file your workbooks in a folder called Documents which is associated with the user’s name you use on the computer.

[bookmark: _Hlk178019107]Answer this Questions:
· What do you mean by cells in an Excel sheet?
· What do you mean by cell address?
· Can you add cells?
· How do you reference a cell in a formula?





Lecture (3)  
Data Types in Excel
To determine the data type in Excel, right-click on any cell or a range of cells and choose Format Cells. The Number tab here will display the available data types, such as Number, Date, or Text. 
[image: identifying data types in excel]
Selecting the Format Cell option.  

[image: easily accessible lists of the all the data types .]
List of data types in Excel.
Alternatively, you can go to the Number group from the home tab and see the data types.
[image: Identifying data types at home tab.]
Different data types as displayed in the home tab. 

Different Data Types in Excel
Data types help you insert data into the document correctly. If there are incorrect data types within the dataset, the data can be misrepresented and cause calculation errors. So, knowing what data types are suitable for datasets is important. Let’s take a look at some common data types in Excel:
1- Number data
Number data can be any value, including large numbers, small fractions, or qualitative data. In this section, we will take a look at examples including currency amounts, whole numbers, percentages, decimals, dates, times, and telephone numbers. As we will see, in order to ensure that Excel interprets your numeric data accurately, we have to define them using proper symbols and formats.
Keep in mind, there are subtle differences. For example, in a case where one cell has financial data and another has a date, Excel registers them both as Numeric, yet they are not identical. 
2- Currency  
  You will be familiar with the Currency data type if you work with financial data. It formats monetary values and ensures that financial data is accurately represented by appropriate currency symbols and decimal places.
Here’s how you can apply the currency data type. Here we will convert numbers into currency.
· Select the range of cells you want to change.
· Right-click.
· Select the Format cell option, and a dialog box will appear.
· Go to the Number tab.
· Select the Currency data type and format your values.
[image: Formatting numbers into currency values.]
Converting numbers into Currency Format. Source
[image: Currency formatted values.]
Numbers converted to Currency values.  
   All the selected columns have been converted to the currency data type. You can modify the currency symbol and decimal placement according to your preferences.
3- Date and Time 
Date and Time data types store dates and times in different formats. These formats help with chronological data analysis, scheduling, and time-sensitive calculations. Let’s take a look at the example of how to convert a Text into a Date. For time formatting, follow these steps and select the Time data type instead.
· First, select the cell you want to change.
· Right-click on the cell.
· Select the Format cells option.
· Go to the Number tab.
· Select the Date data type and format your values.
Depending on your goal, there might be additional steps:.
· If you want to write the current time, simply write =NOW(). 
· To convert the date to Text, all you have to do is apply  =TEXT(Cell number, "MM/DD/YYYY").
[image: Navigating to the ‘Date’ data type in excel.]
Changing the text to the Date and Time data types.
[image: Converting values to date and time format in excel.]
Values converted to Date and Time format.  
[image: Implementing the date conversion function.]
Changing Date format to Text data type. 
4- Percentage 
The Percentage data type converts numbers into percentages, making it easier to read and interpret ratio data and proportional values.
Here’s how you can convert numbers to percentages:
· Select the range of cells you want to change.
· Right-click on it.
· Select the Format cell option, and a dialog box will appear.
· Go to the Number tab.
· Select the Percentage data type and format your values.
· Adjust the decimal places.
[image: Formatting numbers into percentages.]
Converting numbers into percentages. Source: Image by author
[image: Converting numbers into percentages.]
Numbers converted into percentages.
	

	1236.25
Will be 1,236.250

	
[image: ]
	1.05
Will be
$1.050

	[image: ]
	0.05
Will be 5.0%



	
[image: ]
	1.5
Will be 1 1/2

	
[image: ]

	300
Will be 3.00E+ 02

	
[image: ]


	

	[image: ]
	



Number formats Summary

	Format
	Description

	General
	Numbers are displayed just the way you type them.

	Number
	You can:
1. Determine the number of decimal places
2. Use thousands separator.
3. Determine how to display negative numbers.

	Currency
	Used for monetary values. You can:
1. Determine the number of decimal places.
2. Choose the currency symbols.
3. Determine how to display negative numbers.

	Date
	Displays date according to the type, location and Calendar that you specify.

	Time
	Displays time according to the type and location that you specify.

	Percentage
	Displays the percent (%) symbol and multiplies the cell value by 100.

You can determine the number of decimal places.

	Fraction
	Displays a number as a fraction. You can determine the type of fraction that you want.

	Scientific
	Displays a number in exponential notation. You can determine the number of decimal places.


Note: if you want to know the serial number for any date you can change the cell format to number, and vice versa.















[bookmark: _Hlk177998102][image: ][image: ][image: ][image: ][image: ]  Experiment (3) TYPING TEXT OR NUMBERS INTO A WORKSHEET4                                   
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1                                                        2

	Try This Yourself:

	
	Before you begin ensure that there is a blank workbook on the screen…

	1
	Click in cell A3 to make this the active cell, type Garden Settings and press [image: ]
When you press [image: ] the next cell down automatically becomes the active cell. By the way, even though the text looks like it is in cells A3 and B3 it really only is in cell A3 – since there is nothing in B3, Excel allows the spill over to be displayed giving the illusion it is in 2 cells…

	2
	Type Pool Covers and press [image: ]

	3
	Repeat the above steps and enter the remaining text in column A as shown

	4
	Click in cell B2 to make this the active cell, type UK and press [image: ]
When you press [image: ] the cell to the right becomes the active cell…

	5
	Enter the remaining text in row 2 as shown



5                                  

Answer this Questions:
· What data types and formats are available in Excel?
· If you drag the fill handle (lower-right corner) of cell A2 downward into cells A3, A4, and A5, what contents will appear in those cells?
[image: ]
·  Jan, Jan, Jan
·  Feb, Mar, blank cell
·  Feb, Mar, Apr
·  FEB, MAB, APR
· If cell A3 contains the text THE DEATH OF CHIVALRY, what will the function =PROPER(A3) return?
·   the death of chivalry
·  The death of Chivalry
·  THE DEATH OF CHIVALRY
·  The Death Of Chivalry



Lecture (4) 
Number group icons on Home Tab
the fourth group is the Number Group of the Home Tab. Also, this group lies after the Clipboard, the Font & the Alignment groups in MS Excel. For instance, we could call the Number-group as the Formatting group as well. Above all, the Format as Table of the Styles Group is also based on the formatting. The formats such as the General, the Number, the Currency and the Accounting etc; are part of the Number group.
1- Number  
1- Choose number format from the list (General, Number, Currency, Short Date, Long Date	etc.).

2- [image: ]Percent Style formats.

3- Thousands Comma Style.

4- Increase Decimal places.

5- Decrease Decimal places.
2-Alignment tab:
1. Horizontal	alignment: [Left, Center, Right]
2. Vertical alignment: [Top, Center, Bottom ]
3. Text control:
· Shrink to fit: will automatically reduce the font size in a cell so that the cell content fits without wrapping.
· [image: ]Wrap text: cell content will appear on multiple lines without changing the column width.
· Merge Cells: Merge two or more adjacent cells, the merged cells become
one cell across multiple rows and columns.
4. Orientation: rotate the text diagonally or vertically. It is a useful wat to label narrow columns. You can rotate the text up, down, clockwise, or counterclockwise, or align text vertically.
5. [image: ]Specify Text direction:
· Left – to - Right.
· Right – to – Left.
3- Font tab 
1- Font Type
2- Font Style [Italic, Bold, Bold Italic]
3- [image: ]Font Size
4- Underline:
[None, Single, Double]
5- Font color
6- Font Effects:
· Strikethrough: draw a line through the selected text or numbers.
· [image: ]Superscript: cell contents positioned slightly higher.
· Subscript: cell contents positioned slightly lower.
• Use subscripts and superscripts for individual characters in a cell.

Font group icons on Home Tab:






[image: ]
4-Border tab
Excel offers different types of borders that you can add to individual cells or ranges of cells in your spreadsheet.
To add borders to selected cell(s):
1. Select the cell or range of cells that you want bordered.
2. Select a line type from the Style area.
3. Select a line color from the Color area.
4. In the Border section of the format cells dialog box, select where you want the border applied.
•	None: to remove borderlines.
•	Outline: borderlines will surround the entire cell or cell range.
•	Inside: borderlines will appear around all cell edges for each selected cell.
[image: ]Border icon on Font group on Home Tab:
5-Fill tab:
Adding a background color or a pattern using fill effects
[image: ]
[image: ]

Fill color icon on Font group on Home Tab:






[bookmark: _Hlk178054043]Experiment (4) APPLYING GENERAL FORMATTING
[image: ][image: ]The Number Format command in the Number group on the HOME tab contains a drop arrow that provides a gallery of the more commonly used number formats. You can apply these formats easily and quickly to a selected cell or range of cells in the worksheet.
	Try This Yourself:

	
Open File
	Before starting this exercise you MUST open the file E1315 Number Formatting_1.xlsx…

	1
	Click in cell D4, hold down [image: ], then click in cell D13 to select the range containing dates

	2
	Click on the HOME tab, then click on the drop arrow for Number Format in the Number group to see a gallery of number formats

	3
	Click on Long Date to make the short dates in the selected range appear as long dates

	4
	Click in cell E4, hold down [image: ], then click in cell E13 to select the range containing units of measure

	5
	Click on the drop arrow for Number Format, then select Number to display these as numbers with 2 decimal places

	6
	Repeat the above steps to change G4:G13 to Currency

	7
	Repeat the above steps and change the following ranges as shown:
H4:H14 Percentage I4:I4 Accounting G15:I15 Currency


[image: ]1
2

[bookmark: _Hlk178054546]Answer this Questions:
1- What data types and formats are available in Excel?

2- How to remove borders applied in Cells? 
1. Select None on Border tab of Format cells
2. Open the list on Border tool in Format Cell toolbar then choose first tool (none)
3. Both of above
4. None of above
3. _____ is not a valid data type in MS-Excel. 
1. Number 
2. Character
3. Label 
4. Date/ Time 
4. What is MS Excel?
1. Spreadsheet 
2. Database Management 
3. Presentation 
4. Workbook 
5. In Microsoft Excel spreadsheets, rows are designated as _______.
A. 1, 2, 3, ....
B. A, B, C, ....
C. A1, B1, C1, ....
D. I, II, III, ....




Lecture 5
Format Cells as Table

· [bookmark: _Hlk177813772][bookmark: _Hlk177813829]Select the Cells.
· Click the Format as Table command in the Styles group on the home tab, and choose the appropriate style.
· Select this check box [My table has headers] if your table has column headings.









 




The table will have drop-down
arrows in their headers; you can remove these arrows by:
· Click the Convert to Range command in the Tools group on the
Design contextual tab
[image: ]
Note: the contextual tab Design appears only when you choose one of the styles.
[image: ]Cell Styles
Cell style is a pre-defined set of formats, such as fonts, font sizes, number formats, borders, and shading.
1. Select the cell, then from Home tab, Styles group, and click on Cell Styles.
2. Choose the suitable style.
Copy Formats with Format Painter
1. Select the cell(s) that you want to copy their formats.
2. On the Home tab, click on the Format Painter icon on the clipboard group.
3. Select the cells where you want to apply the copied formats.
Using Clear command
1. Click the Clear button [image: ] , in the Editing group On the Home tab.
2. Choose one of the following:
· Clear All: will clear all contents, formats, and comments in the selected cells.
· Clear Formats: will clear only the formats in the selected cells.
· Clear Contents: will clear only the contents and leaving the comments and any applied formats in the selected cells.
· [image: ]Clear Comments: will clear any comments in the selected cells if there is any.



Notes:	If you select a cell or a group of cells and then press DELETE from the keyboard, this will clear the cell contents only and leaving the cell formats.
FILLING A SERIES




[image: ][image: ]Experiment (5) QUICK TABLES3

	Try This Yourself:

	6

Open File
	Before starting this exercise you MUST open the file E1355 Quick Analysis_5.xlsx…

	1
	Click in any cell containing data

	2
	Hold down		+ [image: ], then press	to select all of the non-empty cells around the current cell

	3
	Using the scroll bars, scroll to the bottom right corner of the selection, click on the Quick Analysis button, then click on the TABLES tab

	4
	Click on Table to turn the selected range into a table

	5
	Scroll across and on the drop arrow for Position to see sorting and filtering options

	6
	Click on Select All to remove the tick, then click on Effective People Leader so it appears ticked

	7
	Click on [OK] to see only those people with this position title



[image: ]
7






[bookmark: _Hlk178056571]Answer this Questions:
· Excel table styles
· Choose a style when creating a table
· Change a style of an existing table
· Change the default table style an Excel
· Create a custom table style
· Apply a table style without converting data to a table
· Remove table formatting in Excel
















Lecture 6
Fill data automatically in worksheet cells
Fill Handle’ is a tool that you can use to autocomplete lists in Excel.
For example, if you have to enter numbers 1 to 20 in cell A1:A20, instead of manually entering each number, you can simply enter the first two numbers and use the fill handle to do the rest.
the steps to use the fill handle to quickly insert numbers up to 20 1- Select the data set

2- Hover the mouse over the bottom-right edge of the selection, you would see a plus icon appear

3- Click the left button on the mouse and drag it down. Excel identifies a pattern of the first 2 numbers (an increment of 1) and uses that to fill that entire series.

· you can quickly fill cells when the number increments/decrements by 1.
· Note that the fill handle works in both directions. You can either fill down by dragging it down or fill up the dragging it upwards.
· Using fill handle button to switch between (fill series and copy cells)
· You can use fill handle in Excel to autocomplete weekday names. It could either be the three alphabets (Mon, Tue…) or the full name (Monday, Tuesday…).
· using the fill handle to autocomplete dates, additional options become available in the autocomplete options.


Here are the additional options that become available when working with dates:

· Fill Days: It will fill the list with days, if you select this option, it fills the cells with dates that increment by 1 (which is also the default fill in this case).
· Fill Weekdays: It fills the cells with weekdays only, and remove the weekends.
· Fill Months: It fills the cells with incrementing months. In this case, the day number remains the same but the month numbers change.
· Fill Years: It fills the cells with incrementing years. In this case, the day number remains the same but the year changes


[bookmark: _Hlk178055515]Experiment (6)  SELECTING RANGES
A contiguous range is any group of selected cells that form either a square or a rectangle. 
A single cell that is selected is also considered to be a range. Ranges can be selected using the mouse, the keyboard or a combination of the two. Once selected, you can use the range for input, or apply formatting, or copy the cells as required.
	Try This Yourself:

	Open File
	Before starting this exercise you MUST open the file E705 Ranges_1.xlsx...

	1
	Click on cell B7 to select it
Because it is the only cell selected it is the active cell…

	2
	Hold down the [image: ] key and click in cell E10
Even though a range has been selected, the active cell is B7 – it appears in a different colour and its contents appear in the formula bar. You can keep the range selected and change the active cell within the range using the keyboard…

	3
	Press [image: ] several times and watch the various cells become active through the selection

	4
	Click in cell B7, hold down the mouse button, and drag down to cell C10 before releasing the mouse
The previous selection has disappeared and the range B7 to C10 is now selected…

	5
	Press [image: ] and [image: ] to
deselect the selected cells and return the cell pointer to cell A1


[image: ]
Lecture (7)
Insert columns or Rows 
Insert columns or Rows:
1- Insert Columns:
Select the column to the right of where you want the new column to appear. The new column always appears to the left of the selected column (i.e., before the selected column). On the Home tab, click the Insert command in the Cells group
>Insert Sheet Columns.
[image: ]





2- Insert rows:
· Select the row to the bottom of where you want the new row to appear. The new row always appears above the selected row. On the Home tab, click the Insert command in the Cells group  Insert Sheet Rows.
Or: Right click on the column or Row where you want the new one to appear. Choose Insert form the list.

Delete columns or Rows:
· Select the column or row. On the Home tab, click the Delete command in the Cells group.
Or: Right click on the column, choose Delete form the list.
[image: ]




Hide rows or columns:
1. [image: ]Select the rows or column headings that you want to hide.
2. Right-click the selected, and then select Hide or Click the Format button in the Cells group on the Home tab and click on Hide & Unhide.
3. Click on Hide Rows or Hide Columns.
NOTE:
· [image: ]The rows heading numbers order are indicator that you've hidden rows.
· The columns heading alphabetical order are indicator that you've hidden columns. [image: ]

Unhide (show) rows or columns:
1. Select the adjacent rows for the hidden rows.Right-click the selected rows, and then select Unhide
Or Click the Format button in the Cells group on the Home tab and click on
Hide & Unhide. Click on Unhide Rows or Unhide Columns.
· Answer this Questions:
· How to insert multiple rows or columns in an Excel worksheet
· How Delete Rows and Columns in Excel.









Experiment (7)  SELECTING ROWS
	Try This Yourself:

	

Same File
	Continue using the previous file with this exercise, or open the file E705 Ranges_1.xlsx...

	1
	Press [image: ] + [image: ] to make cell A1
the active cell

	2
	Move the mouse pointer to the row heading for row 5
Notice that the mouse pointer changes to a black arrow that points towards the row…

	3
	Click once on row heading 5 to select the entire row

	4
	Click in cell B7and press [image: ] +
[image: ]
This is the key combination for selecting an entire row…

	5
	Click on the row header for row 7
to select this row

	6
	Hold down [image: ] and click on the row header for row 10
All rows from 7 to 10 will be selected…

	7
	Click in the row header for row 5, then hold down the left mouse button and drag down the row headers to row 10
This is another technique for selecting rows, but it does require a steady hand!


[image: ]If you want to make changes to an entire row, such as bolding all the headings in a row or changing the font of all the cell entries, you must first select the row. This is done by clicking on the row header to the left of the row. Remember that any changes you make will apply to every cell in the row all the way across to column XFD, so be careful. 


Lecture (8)
The Functions in Excel (part1)
A function in Excel is a preset formula, that helps perform mathematical, statistical and logical operations.
all you have to do is enter an equal sign (=) in the cell, followed by the name of the function and the cell range it applies to.
A function is an operation or calculation that returns the desired results. A
function’s inputs are known as “arguments”.
In Microsoft Office Excel, all functions begin with an equal sign (=). This let’s Excel know to treat your inputs, or arguments, as text. Without the use of an equal sign, Excel will not be able to calculate a result.

There are just a few things you need to remember before starting to insert functions into your spreadsheets:
· When typing a function into a cell, don't insert spaces between the equal sign, function name, and arguments.
· [image: ]If you're adding more than one value, separate them with a comma. Below is an example of a function, we typed into a cell:
The function was SUM. The arguments were 5 and 2. We hit Enter, and Excel calculated the function for us:



[image: ]
We could have also entered it in as =5+2. This would have been a regular formula. Instead, the function we used was the SUM function.
· Classwork (by using SUM function, add the contents of the following cells)
· A1 & A2
· F1 & A7
· A1 & A2 & A7
· Sequential Range from A2 to A7

























[bookmark: _Hlk178056829]Experiment (8) Typing Simple Formulas in A Worksheet
[image: ][image: ][image: ][image: ]    The whole idea behind Excel is to get it to perform calculations. In order for it to do this you need to type formulas in the worksheet. Usually these formulas reference existing numbers, or even other formulas, already in the worksheet using the cell addresses of these numbers rather than the actual value in them. Formulas must be typed beginning with an equal sign (=).6
5
3
2

	Try This Yourself:

	
	Continue using the previous file with this exercise...

	1
	Click in cell B8 to make this the active cell

	2
	Type =B3+B4+B5+B6+B7 and
examine what is happening on the screen

	3
	Press [image: ] to enter the formula and move to the next cell
Notice that a calculation has now been performed. We have entered a formula in B8 that says “add the values in B3, B4, B5, B6, and B7 and show them here”…

	4
	Ensure that C8 is the active cell, type =SUM(C3:C7) and press [image: ]
This is an alternative type of formula known as a “function”. Again a calculation will appear in the cell…

	5
	Click in cell B8 and notice that the formula you typed appears in the Formula Bar, while the result of the calculation appears in the worksheet

	6
	Repeat step 5 with cell C8

	7
	Click on the File Tab [image: ] and select Save to save the additions that have been made



Lecture (9)
The Functions in Excel (part2)

The SUM function totals one or more numbers in a range of cells.
1- Select the blank cell in the row below the cells that you want to sum, cell A5 in this example
[image: ]
2- Click the AutoSum command on the Ribbon's Home tab, or use the keyboard shortcut: Alt + =
[image: ]





[image: ]

3- A SUM formula will appear in the active cell, with a reference to the cells above. In the screen shot below, there is a SUM formula in cell A5: =SUM (A1:A4)
NOTE: If all cells are not automatically included, you can extend the frame, to select them.
[image: ]
4- Press the Enter key to complete the entry.


The SUM Function Setup
· Instead of using the AutoSum command to insert the SUM function, you can type the function manually.
· The SUM function setup (syntax) is: SUM(number1, [number2],...).
· It has one required argument: number1
· It also has optional arguments (enclosed in square brackets): [number2],
· These arguments can be cell references, or can be typed into the formula
· In the example above (=SUM (A1:A4)), there is one argument -- a reference to cells A1:A4.

SUMIF function
You use the SUMIF function to sum the values in a range that meet criteria that you specify. For example, suppose that in a column that contains numbers, you want to sum only the values that are larger than 5. You can use the following formula: =SUMIF(B2:B25,">5")
[image: ]
Match criterion exactly
You can calculate a total for rows that meet a specific criterion. In this example only the rows with Pen orders will be included in the total.
1. Select the cell in which you want to see the total
2. Type an equal sign (=) to start the formula
3. Type: SUMIF(
4. Select the cells that contain the values to check for the criterion. In this example, cells A2:A10 will be checked
5. Type a comma, to separate the arguments
6. Type the criterion. In this example, you're checking for text, so type the word	in	double quotes:	"Pen" Note: upper and lower case are treated equally
7. Type a comma, to separate the arguments
8. Select the cells that contain the values to sum. In this example, cells B2:B10 will be summed
[image: ]9.  =SUMIF (A2:A10,"Pen”, B2:B10)
10.Press the Enter key to complete the entry

[bookmark: _Hlk177838368]Experiment (9) USING THE SUM FUNCTION TO ADD
[image: ]One of the most used functions is the SUM function. This function allows you to add the values in a range of cells. The function is written as: =SUM (range or ranges to add). You can type the function, and then use the pointing technique to fill in the arguments. Excel then paints marquees around the cells involved helping you to track your progress.Try This Yourself:
Open File
Before starting this exercise, you MUST open the file E710 Formulas_4.xlsx...
1
Click on B9 then type =sum (
to start the formula
2
Click on B6 to point to this cell as the start, hold down the [image: ] key and click on B8
Notice the relative addressing details, 3R x 1C, that appear in the tool tip…
3
Type) and press [image: ] to complete the function
4
Click on B9, then move the mouse pointer to the fill handle on the lower right corner of the cell and drag across to E9 to fill the selected range with the equivalent functions
5
Click on the Copy command [image: ] on the Clipboard group on the home tab
6
Click on B14, hold down [image: ] and then click on cells B19 and B24
7
Release [image: ] and press [image: ]
to paste equivalent functions into the worksheet






Lecture (10)
The Functions in Excel (part3)

Mean (average) in Excel 
The mean, also called the average, is a measure of spread in statistics. The mean is calculated by adding up all the numbers in your data set and then dividing by the number of items. It may seem like an easy calculation, but it can become quite complex with larger data sets (think—thousands of numbers!).[image: ]

1- Click an empty cell.
2- Type “=AVERAGE(A1:A10)” where A1:A10 is the location of your data set. For example, if you want to find a mean for a data set in cells A1 to A99, type “A1:A99”.
3- Press “Enter” to display the mean
MAX and MIN functions:
The Excel MAX function can tell you what the largest numeric value is in a range of cells. The opposite of MAX is the MIN function, which returns the smallest numeric value in a range of cells
[image: ][image: ]

Excel LARGE Function:
[image: ]
The Excel LARGE function returns a numeric value based on its position in a list when sorted by value in descending order. In other words, LARGE can retrieve the "nth largest" value – 1st largest value, 2nd largest value, 3rd largest value, etc.
[image: ][image: ]

· If array is empty, LARGE returns the #NUM! error value.
· If k ≤ 0 or if k is greater than the number of data points, LARGE returns the #NUM! error value.
· If n is the number of data points in a range, then LARGE (array,1) returns the largest value, and LARGE (array,n) returns the smallest value.
[image: ]Excel SMALL Function

The Excel SMALL function returns a numeric value based on its position in a list when sorted by value in ascending order. In other words, SMALL can return the "nth smallest" value (1st smallest value, 2nd smallest value, 3rd smallest value, etc.) from a set of numeric data.
[image: ]
[bookmark: _Hlk178077202]Experiment (10) CALCULATING AN AVERAGE
The AVERAGE function allows you to average the values in a range of cells. It is written in much the same way as the SUM function, for example,=AVERAGE(range of cells to average). 
[image: ]The average function can be applied using the Functions Wizard, a part of Excel that steps you through the process of creating a function or you can type it in yourself if you are comfortable with it.
	Try This Yourself:

	

Same File
	Continue using the previous file with this exercise, or open the file E710 Formulas_6.xlsx...

	1
	Click on B29 then click on the Insert Function tool [image: ] to display the Insert Function dialog box

	2
	Click on AVERAGE in Select a function then click on [OK] to display the Function Arguments dialog box

	3
	Click on the Range Selector
tool [image: ] for Number1 to roll up
the wizard, then hold down [image: ]

	
	and select the following ranges

	
	B6:B8

	
	B11:B13

	
	B16:B18

	
	B21:B23

	4
	Press [image: ] to complete the range specifications, then click on [OK] to complete the process
Let’s use the AutoSum function…

	5
	Click on B34, then click on the drop arrow for the Sum command [image: ] on the Editing group, then select Average

	6
	Click on B9, hold down [image: ] and click on B14, B19 and B24, then press [image: ] to complete the formula





[image: ]

[image: ]




Lecture (11)
Copy Excel Sheet
Method 1: Use drag and drop to Copy Excel sheet
-	Click on the tab for the sheet that you want to copy, hold down the Ctrl key and drag the tab to the place you want.
[image: Copy Excel sheet by dragging]


Method 2: Copy the sheet within the same workbook
1. On the Home tab, click the Format command in the Cells group and select move or copy sheets OR Right-click on the sheet tab and then click Move  or  Copy from the menu.
2. Excel will open the Move or Copy dialog box.In the Before Sheet list box, select location you want to drop the copy.
3. Check the Create a Copy check box.
[image: ]
Method 3: Copy the sheet to a another workbook
· In the To Book: select the (New Book) option to copy to a new workbook.
· In the To Book: drop-down list, select the workbook to which you want to copy worksheet. [Note that the workbook that you want to copy on it should be opened]
[image: ]














Experiment (11) Copy Excel Sheet

[image: ][image: ]Just as you can copy the contents of cells and ranges within a worksheet, you can duplicate worksheets within a workbook. This technique is ideal for replicating layouts. For example, if you have a budget workbook that contains data for several departments, you can create a worksheet for the first department and then copy it to create identical worksheets for other departments.1

	Try This Yourself:

	
Same File
	Continue using the previous file with this exercise, or open the file E1324 Worksheet Techniques_1.xlsx...

	1
	Right-click on Sheet1 to display the worksheet shortcut menu

	2
	Select Move or Copy to display the Move or Copy dialog box

	3
	Click on Create a copy so it appears ticked, then click on [OK]
The new worksheet is named Sheet1 (2). Let’s create a “template” from this worksheet by deleting unwanted data...

	4
	Select the range B7:E9, then press [image: ] to clear it

	5
	Repeat step 4 to clear the ranges B14:E23, G7:J9 and G14:J23, then press [image: ] + [image: ] to return to cell A1
Now we can copy this “template” to create additional worksheets...

	6
	Repeat steps 1 to 3 three times to create three copies of the template worksheet – this time without data
The final worksheet should be named Sheet1 (5)


[bookmark: _Hlk177840212]Lecture (12)
MOVING A SHEET TO ANOTHER WORKBOOK
Method 1: Use drag and drop to move Excel sheet
Click on the sheet(s) that you want to move and drag them to a new location.
Example: move Sheet1 and Sheet3 to the end of the workbook.
[image: ]

          Method 2: Move the sheet within the same workbook
1. On   the   Home   tab, click the Format command in the Cells group and select move or copy sheets OR Right-click on the sheet tab and then click Move or Copy from the menu. Excel will open the Move or Copy dialog box.
2. In the Before Sheet list box, select location you want to drop the copy.
3. The Create a Copy check box should be empty.
[image: ]
Method 3: Move the sheet to a another workbook
1. In the To Book: select the (New Book) option to move the sheet to a new workbook.
2. In the To Book: drop-down list, select the workbook to which you want to move worksheet.
Remember:
· If you want to copy the sheets, select the Create a Copy check box. Otherwise let this option deselected to move rather than copy the sheet.
· To move or copy a sheet from one Excel file to another, these workbooks should be previously opened.
[image: ]











      To hide a worksheet
1. Select the worksheet that you want to hide.On the Home tab, click the
format command in the Cells group.
2. Under Visibility, click Hide & Unhide, and then click Hide Sheet. OR Right-click on the sheet tab and then click Hide from the menu.
To show a hidden worksheet
1. On the Home tab, click the format command in the Cells group.
2. Under Visibility, click Hide & Unhide, and then click Unhide Sheet.
3. Unhide sheet dialog box will appear; double-click the name of the hidden sheet that you want to show.
OR Right-click on the sheet tab and then click Unhide… from the menu.


















 Experiment (10) Moving Or Copying A Sheet To Another Workbook
	Try This Yourself:

	
Same File
	Continue using the previous file with this exercise, or open the file E1324 Worksheet Techniques_6.xlsx...

	1
	Click on the Maintenance
worksheet tab
We’ll copy this completed data to another workbook...

	2
	Right-click on the worksheet tab to display the shortcut menu, then click on Move or Copy to display the Move or Copy dialog box

	3
	Click on the drop arrow for To book, then select (new book)

	4
	Click on Create a copy so it appears ticked
This will create a new workbook as well as making a copy of the worksheet...

	5
	Click on [OK]
A new workbook will be created and Maintenance will be the only worksheet in the workbook…

	6
	Save the new workbook as Maintenance.xlsx, then close it


 
[image: ][image: ][image: ]

[image: ]






Lecture (12)
Sorting

In Excel you can sort numbers, text or dates, in either ascending or descending  order. If there is blank cells, they are always placed last in a sort.
You can find sort command on:
· Data tab, Sort& Filter group.
· Home tab, Editing group.
Sort Text Data
1. Click any cell in the column that you want to sort by. On the Home tab, select Sort & Filter from Editing group. OR Data tab, Sort& Filter group.
2. Choose either Ascending [image: ] (Sort A to Z) or Descending [image: ] (Sort Z to A) order.
Sort Number Data
1. Click any cell in the column that you want to sort by. On the Home tab, select Sort & Filter from Editing group. OR Data tab, Sort& Filter group.
2. Choose either Ascending [image: ] (Sort Smallest to Largest) or Descending [image: ] (Sort Largest to Smallest) order.
Sort Date Data
1. Click any cell in the column that you want to sort by.On the Home tab, select Sort & Filter from Editing group. Or Data tab, Sort& Filter group.
2. Choose either Ascending [image: ] (Sort Oldest to Newest) or descending [image: ] (Sort Newest to Oldest) order.
Warning: When you Sort your data excel will automatically expands your selection from a single cell to include all adjacent data. It's dangerous to select one column to sort, each row of adjacent data stay the same (i.e. excel will sort only the selected data, the data next to your selection will not be sorted).

Example: If we select Column A to sort in ascending order, Excel show a Sort Warning message
[image: ]









[image: ]If we choose Expand the selection, the result will be:


If we choose Continue with the current selection, the result will be:
[image: ]Note: This option will only sort column A, which means that our data is no longer correct.


MOVING OR COPYING A SHEET TO ANOTHER WORKBOOK
	Try This Yourself:

	
Same File
	Continue using the previous file with this exercise, or open the file E1324 Worksheet Techniques_6.xlsx...

	
	Click on the Maintenance
worksheet tab
We’ll copy this completed data to another workbook...

	
	Right-click on the worksheet tab to display the shortcut menu, then click on Move or Copy to display the Move or Copy dialog box

	❸
	Click on the drop arrow for To book, then select (new book)

	
	Click on Create a copy so it appears ticked
This will create a new workbook as well as making a copy of the worksheet...

	A
	Click on [OK]
A new workbook will be created and Maintenance will be the only worksheet in the workbook…

	
	Save the new workbook as Maintenance.xlsx, then close it


[image: ]



[image: ][image: ]





[image: ]






Lecture (13)
Sorting and Filtering Data With Excel

You can filter data to display a subset of data and analyze information. Filtering is temporarily hiding data in a spreadsheet.
You can find Filter command on:
· Data tab, Sort& Filter group.
· Home tab, Editing group.
· Excel automatically adds Drop-down arrows besides each column heading. Click the drop-down arrow next to the heading you would like to filter.
· The Filter Type depends on the data type in that column.



[image: ]Text Filters
[image: ]Number Filters:

[image: ]


Date Filters:
Quarter1:
January, February, March Quarter 2:
April, May, June Quarter 3:
July, August, September Quarter 4:
October, November, December
[image: ]


Example: The data below filtered by
[image: ]First column. Note that the filter icon is beside the number column and the rows 6, 8, and 9 are hidden.

To clear one filter:
1. [image: ]Click on the drop-down arrows next to a filtered column.
2. Choose Clear Filter From.
Lecture (14)
Insert comments and notes in Excel

Comments allow you to add Notes or more descriptive information to that cell in a popup message. A red triangle appears in the upper right corner of the cell.



Adding Comments:
1. Select the cell. Click New Comment, in
the Comments group on Review tab. Type the comment.
Note: Red triangle appears in the upper right- corner of
the cell. The comment text appears when you place your mouse over the cell.

Editing Comments
Editing a comment allows you to change or add to the information you have placed within a cell as a comment.
1. Select the cell that contains the comment. Click Edit Comment in the Comments group on Review tab.
2. The Comment box appears, make your changes then click another cell.
Deleting Comments
1. Select	the	cell	which	contains	the comment to be deleted.
2. Click	Delete	Comment	in	the
Comments group, on Review tab.
Note: you can delete a comment by Clear
command in the Editing group, on Home tab. From the list choose Clear Comments.
[image: ]

Show All Comments
By default, the comments appear only when you hover over the cell that contains the comment to show all the comments at once.
- Click Show All Comments, in the Comments group On the Review tab.
[image: ]


Navigate between Comments
Click Previous & Next, in the Comments group On the Review tab to navigate through the comments.


Refrence 
1- Held, Bernd, Brian Moriarty, and Theodor Richardson. Microsoft Excel Functions and Formulas with Excel 2019/Office 365. Mercury Learning and Information, 2019.
2- Harvey, Greg. Excel 2019 for dummies. John Wiley & Sons, 2018.
3- Shmueli, Galit, Nitin R. Patel, and Peter C. Bruce. "Data mining in excel: Lecture notes and cases." (2007).
4- 	أساسيات الحاسوب وتطبيقاته المكتبية / 4 أجزاء – أ.د. غسان حميد عبد المجيد  و .د. زياد محمد عبود  واخرون.
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Click on the row header for row 7
to select this row

Hold down [jjij and click on the
row header for row 10

All rows from 7 to 10 will be
selected...

Click in the row header for row 5,
then hold down the left mouse
button and drag down the row
headers to row 10

This is another technique for
selecting rows, but it does require
a steady hand!
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Try This Yourself:

©0

Continue using the previous
file with this exercise...

Click in cell B8 to make this
the active cell

Type =B3+B4+B5+B6+B7 and
examine what is happening on
the screen

Press [l to enter the formula
and move to the next cell

Notice that a calculation has
now been performed. We have
entered a formula in B8 that
says “add the values in B3, B4,
B5, B6, and B7 and show them
here”...

Ensure that C8 is the active
cell, type =SUM(C3:C7) and
press [l

This is an alternative type of
formula known as a “function”.
Again a calculation will appear
in the cell...

Click in cell B8 and notice that
the formula you typed appears
in the Formula Bar, while the
result of the calculation
appears in the worksheet

Repeat step 5 with cell C8

Click on the File Tab -
and select Save to save the
additions that have been made
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Ensure that C8 is the active
cell, type =SUM(C3:C7) and
press [l
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formula known as a “function”.
Again a calculation will appear
in the cell...

Click in cell B8 and notice that
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Try This Yourself:
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Continue using the
previous file with this
exercise, or open the file
E1324 Worksheet
Techniques_6.xIsx...

Click on the Maintenance
worksheet tab

We’ll copy this completed
data to another workbook...

Right-click on the
worksheet tab to display
the shortcut menu, then
click on Move or Copy to
display the Move or Copy
dialog box

Click on the drop arrow for
To book, then select (new
book)

Click on Create a copy so
it appears ticked

This will create a new
workbook as well as
making a copy of the
worksheet...

Click on [OK]

A new workbook will be
created and Maintenance
will be the only worksheet
in the workbook...

Save the new workbook as
Maintenance.xIsx, then
close it
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